summaryrefslogtreecommitdiff
path: root/dev-vcs/topgit/topgit-0.19.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/topgit/topgit-0.19.12.ebuild')
-rw-r--r--dev-vcs/topgit/topgit-0.19.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/topgit/topgit-0.19.12.ebuild b/dev-vcs/topgit/topgit-0.19.12.ebuild
new file mode 100644
index 000000000000..eab7ae62e258
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.19.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://mackyle.github.io/topgit/topgit.html https://github.com/mackyle/topgit"
+SRC_URI="https://github.com/mackyle/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND=">=dev-vcs/git-2.10.0"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" sharedir="/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}