summaryrefslogtreecommitdiff
path: root/dev-vcs/stgit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/stgit')
-rw-r--r--dev-vcs/stgit/Manifest2
-rw-r--r--dev-vcs/stgit/stgit-1.4.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index 8320c3e06611..1a6adf8a441a 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -1,3 +1,5 @@
DIST stgit-1.1.tar.gz 313862 BLAKE2B 2d15ba7c2f55ff1211f0d9a3002878102f5023e897d0830daa688a2af8c6a386ec0cf076c728b6f45650ee3382379a32fb4efb25d0da3b28302f158dfca6ef62 SHA512 917c645f219b2725d1e88186674a6184c96f1457d5c7722b4da17931d963f0fe0c675cdaaca435ba7405ba498d6db9a01c9f554d1aa3093cc3205d224d9d9759
+DIST stgit-1.4.tar.gz 390734 BLAKE2B a2c8b6848cacd743022318ebf9a0512c6bd02a2b8c864db2270e5075c82dfd9e6037a3a79978b2061487bf040864077b0f7836c66986d82ff3eb902331589d87 SHA512 5251dc26a7c64dcc83021399f95ea911d6b65cfb2ee5c016c886447740ed48b66d3f0bd92a45b4aed40ae2e77dfe6ba62336dbba6773a1879ab749c95bb99b4b
EBUILD stgit-1.1.ebuild 1840 BLAKE2B 06b57cfc1df07ac5b62045f765c3d6e03083e1132c12e6d775d5d637a2d4e8fba5a8779e639e9adac07c11c166fa7378d8fe341f53039a4b58a9714d9ed2e9eb SHA512 e365bd59428eef6feb3c71b1282753127f48f49c51408878957a490bf27d426eb70b8d45eb10f92e39dddaeae31f5c3b5eda769d909540994b00631c626c7965
+EBUILD stgit-1.4.ebuild 1848 BLAKE2B daa16c4d0766dff8e8db67a9c4d18e59e907d5a0f38ff790141592ed10f06f1e3687e4054f2e68b07f82d30b1cb646b88992303c0b804a920495778b890dad9d SHA512 8fc12389ad0378c3514efec93bc0ac4ed7d71dc1ef86d0ce495e07c7322762959d7104cd51bbb33772b8b0fe3eece7a0ccb86f36cb5ab3e2a6ee9ab593eb7a18
MISC metadata.xml 347 BLAKE2B 152f011c7facd06cc1c654f388b4a44bbd8486549c07f1329d228e252a411bfb565e4f5b9e37bf9eefc23fda47a774c347d2e82070ac21c0880806bca99a6685 SHA512 04b087c0e6c6ae99128dab9c29e49d55e1cbcac3890f6324d3ea66b14530e92ca9ed32e9a6dfa23f06e23f8b79b3e57ceff2c9cc2995af4e01c91914d50361d0
diff --git a/dev-vcs/stgit/stgit-1.4.ebuild b/dev-vcs/stgit/stgit-1.4.ebuild
new file mode 100644
index 000000000000..06367525ebb8
--- /dev/null
+++ b/dev-vcs/stgit/stgit-1.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="https://stacked-git.github.io"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp completion/stgit.bash 'stg'
+}