summaryrefslogtreecommitdiff
path: root/dev-vcs/stgit/stgit-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/stgit/stgit-2.2.0.ebuild')
-rw-r--r--dev-vcs/stgit/stgit-2.2.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-vcs/stgit/stgit-2.2.0.ebuild b/dev-vcs/stgit/stgit-2.2.0.ebuild
index c1d5ca48fd91..5c031f871323 100644
--- a/dev-vcs/stgit/stgit-2.2.0.ebuild
+++ b/dev-vcs/stgit/stgit-2.2.0.ebuild
@@ -175,7 +175,7 @@ CRATES="
xattr-0.2.3
"
-inherit cargo
+inherit cargo flag-o-matic
DESCRIPTION="Manage a stack of patches using GIT as a backend"
HOMEPAGE="https://stacked-git.github.io"
@@ -196,6 +196,10 @@ RDEPEND=""
# update with proper path to binaries this crate installs, omit leading /
QA_FLAGS_IGNORED="usr/bin/${PN}"
+src_configure() {
+ filter-lto #bug 897692
+}
+
src_compile() {
cargo_src_compile
emake completion