summaryrefslogtreecommitdiff
path: root/dev-vcs/qsvn/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/qsvn/files')
-rw-r--r--dev-vcs/qsvn/files/qsvn-0.8.3-gcc6.patch11
-rw-r--r--dev-vcs/qsvn/files/qsvn-0.8.3-static-lib.patch23
-rw-r--r--dev-vcs/qsvn/files/qsvn-0.8.3-tests.patch12
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-vcs/qsvn/files/qsvn-0.8.3-gcc6.patch b/dev-vcs/qsvn/files/qsvn-0.8.3-gcc6.patch
new file mode 100644
index 000000000000..d4f75fb1e48e
--- /dev/null
+++ b/dev-vcs/qsvn/files/qsvn-0.8.3-gcc6.patch
@@ -0,0 +1,11 @@
+--- a/svnqt/contextdata.cpp
++++ b/svnqt/contextdata.cpp
+@@ -748,7 +748,7 @@
+
+ svn_config_get(cfg, &mimetypes_file,
+ SVN_CONFIG_SECTION_MISCELLANY,
+- SVN_CONFIG_OPTION_MIMETYPES_FILE, false);
++ SVN_CONFIG_OPTION_MIMETYPES_FILE, NULL);
+ if (mimetypes_file && *mimetypes_file) {
+ if ((err = svn_io_parse_mimetypes_file(&(m_ctx->mimetypes_map),
+ mimetypes_file, pool))) {
diff --git a/dev-vcs/qsvn/files/qsvn-0.8.3-static-lib.patch b/dev-vcs/qsvn/files/qsvn-0.8.3-static-lib.patch
new file mode 100644
index 000000000000..a0e50aadf223
--- /dev/null
+++ b/dev-vcs/qsvn/files/qsvn-0.8.3-static-lib.patch
@@ -0,0 +1,23 @@
+--- a/svnqt/CMakeLists.txt 2009-07-05 04:56:34.000000000 -0500
++++ b/svnqt/CMakeLists.txt 2009-08-25 00:56:52.432416800 -0500
+@@ -131,7 +131,7 @@ CONFIGURE_FILE(
+ SET(INST_HEADERS ${INST_HEADERS} ${CMAKE_CURRENT_BINARY_DIR}/svnqt_defines.hpp)
+ INCLUDE_DIRECTORIES(BEFORE ${CMAKE_CURRENT_BINARY_DIR})
+
+-ADD_LIBRARY(${svnqt-name} SHARED ${SOURCES} ${svnhdr})
++ADD_LIBRARY(${svnqt-name} STATIC ${SOURCES} ${svnhdr})
+ IF(WIN32)
+ ADD_DEFINITIONS(-D_USE_32BIT_TIME_T)
+ ELSE(WIN32)
+@@ -175,9 +175,11 @@ ENDIF (BUILD_TESTS)
+ # install rules
+ # in win32 we don't install it
+ IF(NOT WIN32)
++IF(FALSE)
+ INSTALL(TARGETS ${svnqt-name} DESTINATION ${LIB_INSTALL_DIR})
+ INSTALL(FILES ${INST_HEADERS} DESTINATION include/svnqt)
+ INSTALL(FILES ${CACHEINST_HEADERS} DESTINATION include/svnqt/cache)
++ENDIF(FALSE)
+ ENDIF(NOT WIN32)
+
+ IF (BUILD_TESTS)
diff --git a/dev-vcs/qsvn/files/qsvn-0.8.3-tests.patch b/dev-vcs/qsvn/files/qsvn-0.8.3-tests.patch
new file mode 100644
index 000000000000..e61f116c84f3
--- /dev/null
+++ b/dev-vcs/qsvn/files/qsvn-0.8.3-tests.patch
@@ -0,0 +1,12 @@
+The included tests are simple, "hello world" style tests
+that do not actually test this package.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -187,7 +187,3 @@
+ /dVcInstallDir=$ENV{VCINSTALLDIR}
+ )
+ ENDIF (WIN32)
+-
+-# Unit-Tests
+-ENABLE_TESTING()
+-ADD_SUBDIRECTORY(tests)