summaryrefslogtreecommitdiff
path: root/dev-vcs/qgit/qgit-2.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/qgit/qgit-2.7-r1.ebuild')
-rw-r--r--dev-vcs/qgit/qgit-2.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/qgit/qgit-2.7-r1.ebuild b/dev-vcs/qgit/qgit-2.7-r1.ebuild
new file mode 100644
index 000000000000..b7930738acae
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Qt GUI for git repositories"
+HOMEPAGE="http://libre.tibirna.org/projects/qgit/wiki/QGit"
+SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+ !dev-vcs/qgit:2
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=(
+ "${FILESDIR}/${P}-highdpi-support.patch"
+ "${FILESDIR}/${P}-qt-5.11.patch"
+)