summaryrefslogtreecommitdiff
path: root/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild
deleted file mode 100644
index a622256dbf98..000000000000
--- a/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="Python command line interface to gitlab API"
-HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="test"
-
-BDEPEND="test? (
- dev-python/httmock[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
-
-distutils_enable_tests unittest
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r *.rst docs
-}