summaryrefslogtreecommitdiff
path: root/dev-vcs/pwclient/pwclient-2.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/pwclient/pwclient-2.6.2.ebuild')
-rw-r--r--dev-vcs/pwclient/pwclient-2.6.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-vcs/pwclient/pwclient-2.6.2.ebuild b/dev-vcs/pwclient/pwclient-2.6.2.ebuild
new file mode 100644
index 000000000000..6ffd451e343d
--- /dev/null
+++ b/dev-vcs/pwclient/pwclient-2.6.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="The command-line client for the patchwork patch tracking tool"
+HOMEPAGE="https://github.com/getpatchwork/pwclient"
+SRC_URI="https://github.com/getpatchwork/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_compile() {
+ export PBR_VERSION=${PV}
+ distutils-r1_src_compile
+}