summaryrefslogtreecommitdiff
path: root/dev-vcs/pre-commit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest4
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.12.1.ebuild56
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.13.0.ebuild2
3 files changed, 2 insertions, 60 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 86e8a22eb368..bd222953c09f 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,5 +1,3 @@
-DIST pre-commit-2.12.1.tar.gz 246313 BLAKE2B 45ee7c8217f88eeaa2e9eb11efd79291d6577134799b328f252bd4d4283c11754b36ffeedf045a5101c6edc8cdf330d566e404ae34f1a831a830e8e0346337e9 SHA512 6dbd804e1001276e6e8cea7c31b321a05798b38c59f37d5900317c3a9ceccf5103afcbdfd29f9438be3595a18ae15eb09dd222c91c439da47d7728a0e0a55c70
DIST pre-commit-2.13.0.tar.gz 252631 BLAKE2B 7e6b3af46dfaf9928d2cb2aa6cad05423bf6e417e2324af71b241e1aaa2eec6fcb271869f98c040cd4fb8c608a1fabd244c8286864f469a06c44684cd2bf33eb SHA512 5dfc297b3f900afef8f1c355b38ce086af7c836d1e577af8ec95ffb30e82df8b866131da4ff12933339bda63e4a90833c3852265d4f2d4a59bf92bce2b972a5e
-EBUILD pre-commit-2.12.1.ebuild 1711 BLAKE2B f21a7772ffedf6cfffcebae0c6e57e90c4e94e7818d210b6d961f653f2e262e75e957b4bf5ebc9e826a2ed7876dcefdf6096b0eec84008d316ad655295d6860b SHA512 f3149dde9bb2242abe4ffa32be2e3cac7041c6d36644568e98fec98c0de189ece1b4002fe14d127f34d3cbedb8b960c07d582a543986ca68394aee897f4047a4
-EBUILD pre-commit-2.13.0.ebuild 2073 BLAKE2B de50198f560d2f445d4dfc6de9ecfc915bdafe6078fb7efd6e8b9c3b226133e701b2e7174b0910eff62b975268887bff3d400c7fac90f1a8ff7b04dedb3cba32 SHA512 bbb833786557c89da7d6f5ca1a10f2b3613091a5cf643721dfa01de84ae505cef255250d0a82e982de6f399ea44ad90956fedc7c4d587437a8ef35b0759c9644
+EBUILD pre-commit-2.13.0.ebuild 2072 BLAKE2B 9ee972af0cff9c270309c02716afa63a74605b99d4b95d02a1f715f66a4a615bd489cd0b99245f288e0a6574d948d3a57114a25ef182964721f3060193c53bda SHA512 ea0583b7859da28373fe2d8f8496e06892d21d96a5e79cb6d8a7ddc5cd9c87edb1be50f21d610c6ecf7ad2f251a6b9c7bf9ca7c77830021788ad859aada5b3d7
MISC metadata.xml 379 BLAKE2B 6224574b28f758241c6ad965ad59a423db76bd21c64c3577691104a8f45a4ee9b570f9cf1557f2ce17f00bf496b9eeb83741679dc0d6e1bb23c421f90fe9070f SHA512 f14032e386c2bb591390034086c7d4a2e8ce9aacc536574c517dff4691aa8c39bc966307ee91a5f76708f14601312fd16528a676e1918d82b2761185bc27df9f
diff --git a/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild b/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild
deleted file mode 100644
index 1dd37b2abb3b..000000000000
--- a/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-# TODO: figure out why these tests - all of which invoke git - fail:
-# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall]
-# "Git failed", not much information beyond that
-# - tests/main_test.py::test_try_repo
-# Ditto
-# - tests/commands/install_uninstall_test.py::test_installed_from_venv
-# "git commit" returns 1 instead of 0, again no details
-RESTRICT="test"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- dev-python/cfgv[${PYTHON_USEDEP}]
- dev-python/identify[${PYTHON_USEDEP}]
- dev-python/nodeenv[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
- ')"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
-)"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- default
-
- # These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
- # and while some of them do include "skip if not found" logic, most of them do not.
- rm -rf tests/languages tests/repository_test.py
-}
diff --git a/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild
index 3d3e6ce0d2ed..802f0287c55a 100644
--- a/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~hppa"
+KEYWORDS="amd64 ~hppa"
# TODO: figure out why these tests - all of which invoke git - fail:
# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall],