summaryrefslogtreecommitdiff
path: root/dev-vcs/hub/hub-2.14.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hub/hub-2.14.1.ebuild')
-rw-r--r--dev-vcs/hub/hub-2.14.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/hub/hub-2.14.1.ebuild b/dev-vcs/hub/hub-2.14.1.ebuild
new file mode 100644
index 000000000000..02a51219754b
--- /dev/null
+++ b/dev-vcs/hub/hub-2.14.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="https://github.com/github/hub/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+src_compile() {
+ emake bin/hub man-pages
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+ doman share/man/man1/*.1
+
+ newbashcomp etc/${PN}.bash_completion.sh ${PN}
+
+ insinto /usr/share/vim/vimfiles
+doins -r share/vim/vimfiles/*
+ insinto /usr/share/zsh/site-functions
+ newins etc/hub.zsh_completion _${PN}
+}