summaryrefslogtreecommitdiff
path: root/dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild')
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild
new file mode 100644
index 000000000000..a10a7ca95686
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories"
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home https://pypi.org/project/hgsubversion/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+# although any ref absent in the source, tests fail badly with >=mercurial-2.8.1
+RDEPEND=">=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
+ dev-vcs/mercurial[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/subvertpy-0.7.4[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.5[python] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( README )
+
+#python_test() {
+# "${PYTHON}" tests/run.py || die "Tests failed under ${EPYTHON}"
+#}