summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git/git-9999-r1.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index ff37be69674c..fdd0f6f7d758 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -55,7 +55,10 @@ IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl
# Common to both DEPEND and RDEPEND
DEPEND="
- gnome-keyring? ( app-crypt/libsecret )
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
@@ -66,7 +69,6 @@ DEPEND="
net-misc/curl
webdav? ( dev-libs/expat )
)
- emacs? ( >=app-editors/emacs-23.1:* )
iconv? ( virtual/libiconv )
"
@@ -111,6 +113,8 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
+ emacs? ( >=app-editors/emacs-23.1:* )
+ gnome-keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -338,7 +342,7 @@ src_compile() {
if use gnome-keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
- git_emake || die "emake git-credential-libsecret failed"
+ git_emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PKG_CONFIG="$(tc-getPKG_CONFIG)"
popd &>/dev/null || die
fi