summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git/git-9999-r1.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index a2c9d157f9ed..d375f35e5ccf 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,7 +50,7 @@ if [[ ${PV} != *9999 ]]; then
SRC_URI+=" doc? ( ${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX} )"
if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
fi
@@ -261,7 +261,10 @@ src_prepare() {
if use prefix ; then
# bug #757309
- eapply "${FILESDIR}"/git-2.37.2-darwin-prefix-gettext.patch
+ sed -i \
+ -e 's:/usr/local/opt/gettext/:/do/not/look/elsewhere/:g' \
+ -e 's:/opt/homebrew/:/do/not/look/elsewhere/:g' \
+ config.mak.uname || die
fi
sed -i \
@@ -567,7 +570,6 @@ src_install() {
local contrib_objects=(
buildsystems
fast-import
- hg-to-git
hooks
remotes2config.sh
rerere-train.sh