summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-2.16.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git/git-2.16.1.ebuild')
-rw-r--r--dev-vcs/git/git-2.16.1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-vcs/git/git-2.16.1.ebuild b/dev-vcs/git/git-2.16.1.ebuild
index 67a7f811554e..67db3890c141 100644
--- a/dev-vcs/git/git-2.16.1.ebuild
+++ b/dev-vcs/git/git-2.16.1.ebuild
@@ -45,7 +45,7 @@ if [[ ${PV} != *9999 ]]; then
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
[[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -572,7 +572,7 @@ src_install() {
}
src_test() {
- local disabled="t9128-git-svn-cmd-branch.sh"
+ local disabled=""
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
@@ -603,7 +603,7 @@ src_test() {
# Unzip is used only for the testcase code, not by any normal parts of Git.
if ! has_version app-arch/unzip ; then
einfo "Disabling tar-tree tests"
- disabled="${disabled} t5000-tar-tree.sh"
+ disabled+=" t5000-tar-tree.sh"
fi
cvs=0
@@ -612,10 +612,10 @@ src_test() {
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
einfo "Skipping other tests that require being non-root"
- disabled="${disabled} ${tests_nonroot}"
+ disabled+=" ${tests_nonroot}"
else
[[ $cvs -gt 0 ]] && \
has_version dev-vcs/cvs && \
@@ -625,17 +625,17 @@ src_test() {
let cvs=$cvs+1
if [[ $cvs -lt 3 ]]; then
einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
fi
if ! use perl ; then
einfo "Disabling tests that need Perl"
- disabled="${disabled} ${tests_perl}"
+ disabled+=" ${tests_perl}"
fi
einfo "Disabling tests that fail with SVN 1.7"
- disabled="${disabled} ${test_svn}"
+ disabled+=" ${test_svn}"
# Reset all previously disabled tests
cd "${S}/t"