summaryrefslogtreecommitdiff
path: root/dev-vcs/git-spindle/git-spindle-3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-spindle/git-spindle-3.3.ebuild')
-rw-r--r--dev-vcs/git-spindle/git-spindle-3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-vcs/git-spindle/git-spindle-3.3.ebuild b/dev-vcs/git-spindle/git-spindle-3.3.ebuild
new file mode 100644
index 000000000000..9ebebd0d3a0b
--- /dev/null
+++ b/dev-vcs/git-spindle/git-spindle-3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Git subcommands for interacting with central services"
+HOMEPAGE="http://seveas.github.io/git-spindle/"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-vcs/git
+ ${PYTHON_DEPS}"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"