summaryrefslogtreecommitdiff
path: root/dev-vcs/git-deploy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-deploy')
-rw-r--r--dev-vcs/git-deploy/Manifest3
-rw-r--r--dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild67
-rw-r--r--dev-vcs/git-deploy/metadata.xml8
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-vcs/git-deploy/Manifest b/dev-vcs/git-deploy/Manifest
new file mode 100644
index 000000000000..1cc9edb8813f
--- /dev/null
+++ b/dev-vcs/git-deploy/Manifest
@@ -0,0 +1,3 @@
+DIST git-deploy-6.0.1_p20131024.tar.gz 55394 BLAKE2B 7d2f7578948033e182e271c44752be27bcddc4b2480a795d110675feea9408ac7b786b135f058f224f5edcbb184bcd022b19bb3d7614a366ec29b2ea4d5f6d2b SHA512 cf3504b8f40d86cd8322ed93f2fe43593bcbf2db37685d3337b89501f39b38298dfb6d6cd51dd3f518f6048b680446a1660b85887ef73647829608e77b497634
+EBUILD git-deploy-6.0.1_p20131024.ebuild 1401 BLAKE2B a5d65369e12757b875b4e80cb0c7ad56c406f10dd498716fc16664c06a45b311641f7061b3437f814a95e744d2150b4e64abacdb7daf967b3c3039a99bf2bd32 SHA512 63b71fd006776eff4cc7a77311746446796fc3a230ca61756455861c76bef72a7cd4a0cbcc70c17e05456d76ab3425e37f8a6d7b5ea6712123837e99b78912ab
+MISC metadata.xml 253 BLAKE2B 418a1c1e806a98951e739e1e18cc2a0417643c0629c49cec5e7e51f8de4bebf072c046bf749e757d5723dd41064544f18514c12dfd3b9c9c47c6c74167fafbf5 SHA512 21be5cc9f7b4fc3af74661ab49aa067574a2028f25c5175aa4d137ab77d00c51fa705c44a94e13b784d91ecf9d4e43a4a4ccf0abf63aed814e9382448519ae82
diff --git a/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild b/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild
new file mode 100644
index 000000000000..da2005af964f
--- /dev/null
+++ b/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-app
+
+COMMIT="e9ef93debd12d85e70676dd79b4bd78ac2b05271"
+
+DESCRIPTION="make deployments so easy that you'll let new hires do them on their
+first day"
+HOMEPAGE="https://github.com/git-deploy/git-deploy"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="dev-vcs/git
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Time-HiRes
+ virtual/perl-Memoize
+ virtual/perl-Data-Dumper"
+DEPEND="dev-lang/perl
+ test? (
+ ${COMMON_DEPEND}
+ virtual/perl-File-Temp
+ )"
+RDEPEND="dev-lang/perl
+${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ pod2man -n git-deploy README.pod > git-deploy.1 || die
+}
+
+src_test() {
+ local testdir=${TMPDIR}/git-deploy-test
+
+ # Prepare for tests
+ cp -a "${S}/" $testdir || die
+ cd $testdir || die
+
+ git config --global user.name "git-deploy" || die
+ git config --global user.email "git-deploy@localhost" || die
+
+ git init . || die
+ git add . || die
+ git commit -a -m 'git-deploy testing' || die
+
+ USER="git-deploy" perl t/run.t || die
+}
+
+src_install() {
+ dobin git-deploy
+
+ insinto $VENDOR_LIB
+ doins -r lib/Git
+
+ doman git-deploy.1
+
+ newdoc Changes ChangeLog
+}
diff --git a/dev-vcs/git-deploy/metadata.xml b/dev-vcs/git-deploy/metadata.xml
new file mode 100644
index 000000000000..115e717d1b5e
--- /dev/null
+++ b/dev-vcs/git-deploy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">git-deploy/git-deploy</remote-id>
+ </upstream>
+</pkgmetadata>