summaryrefslogtreecommitdiff
path: root/dev-vcs/git-deploy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-deploy')
-rw-r--r--dev-vcs/git-deploy/Manifest5
-rw-r--r--dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild67
-rw-r--r--dev-vcs/git-deploy/metadata.xml8
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-vcs/git-deploy/Manifest b/dev-vcs/git-deploy/Manifest
new file mode 100644
index 000000000000..325c78080325
--- /dev/null
+++ b/dev-vcs/git-deploy/Manifest
@@ -0,0 +1,5 @@
+DIST git-deploy-6.0.1_p20131024.tar.gz 55394 SHA256 fe5b810ed3a9595f1d2c733d1fd42f83ff8a1f1995f3d4a11f1f9b006d0a94a1 SHA512 cf3504b8f40d86cd8322ed93f2fe43593bcbf2db37685d3337b89501f39b38298dfb6d6cd51dd3f518f6048b680446a1660b85887ef73647829608e77b497634 WHIRLPOOL 0a6a1e8178d771f6d32967ce748fde883c5604da75a9c37fed06291e183dfe5a90321be0d23a593a72e68882ed44b0d7abba3a85264642f057f962b476115c0c
+EBUILD git-deploy-6.0.1_p20131024.ebuild 1401 SHA256 4475190e53235208c580cfcd87900ff85a1f6c116e01628ba398dec8edecfb71 SHA512 63b71fd006776eff4cc7a77311746446796fc3a230ca61756455861c76bef72a7cd4a0cbcc70c17e05456d76ab3425e37f8a6d7b5ea6712123837e99b78912ab WHIRLPOOL 4dc0c9e234968bafd13657a4f78d1aaf33720e6035a12b4c30af524024df86080494f935b13fbf6be970e7a1d7fccac7c4edb86934cfd8d22289179319e88f18
+MISC ChangeLog 2502 SHA256 2290a94c20fc1a8423105f941806fb2f265ad913253de81f2b58fc6a941d079c SHA512 a01fe77158d95d0f59a3afbd6b06ef0bdeea19e60b32b0d1d76d6ea168e4dcdf1c54f1bb71840bff140dc6dfd995fba60085270455d569aa4dfc558261fbb98d WHIRLPOOL c14424723154e164f024b144a60993d2a26717383c7d0d663cf56af2c88a836e255c78bc3daf3ac001855c6226694d4ea6746f4305b08a5f1107a5c0facf0efb
+MISC ChangeLog-2015 562 SHA256 3df929feccdb9e2ae520153216e7354a1e5f790050ec79970c930ae234b16a8b SHA512 8fa4dd7bce66c5cfd09fc560abe66f69bd7302e1d287f3d35db766e99719be511cfe8e4f7537b726662c10ffce3ef1028348ae4e01414fc6a95212f521b5444e WHIRLPOOL bfb4d11789d8ecaa0c35a46fb07dec98fe70de5ad17d3c686cbe48a05bda3baeeafb59fe7192034ede539b090025b5e2982badfce80a3e46889ece4c6842531b
+MISC metadata.xml 253 SHA256 db21cc51728783228df36f0dd12ac46b19809502fb363dfaa3e2043d0a3900bd SHA512 21be5cc9f7b4fc3af74661ab49aa067574a2028f25c5175aa4d137ab77d00c51fa705c44a94e13b784d91ecf9d4e43a4a4ccf0abf63aed814e9382448519ae82 WHIRLPOOL 8224cd80071b5e2a79ae48028b76696874c23a086e6d4581de87e487802195a421fd536c258688876a5568a30b59e6c071502d7faefd2610dda2a6c9c542a808
diff --git a/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild b/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild
new file mode 100644
index 000000000000..da2005af964f
--- /dev/null
+++ b/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-app
+
+COMMIT="e9ef93debd12d85e70676dd79b4bd78ac2b05271"
+
+DESCRIPTION="make deployments so easy that you'll let new hires do them on their
+first day"
+HOMEPAGE="https://github.com/git-deploy/git-deploy"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="dev-vcs/git
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Time-HiRes
+ virtual/perl-Memoize
+ virtual/perl-Data-Dumper"
+DEPEND="dev-lang/perl
+ test? (
+ ${COMMON_DEPEND}
+ virtual/perl-File-Temp
+ )"
+RDEPEND="dev-lang/perl
+${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ pod2man -n git-deploy README.pod > git-deploy.1 || die
+}
+
+src_test() {
+ local testdir=${TMPDIR}/git-deploy-test
+
+ # Prepare for tests
+ cp -a "${S}/" $testdir || die
+ cd $testdir || die
+
+ git config --global user.name "git-deploy" || die
+ git config --global user.email "git-deploy@localhost" || die
+
+ git init . || die
+ git add . || die
+ git commit -a -m 'git-deploy testing' || die
+
+ USER="git-deploy" perl t/run.t || die
+}
+
+src_install() {
+ dobin git-deploy
+
+ insinto $VENDOR_LIB
+ doins -r lib/Git
+
+ doman git-deploy.1
+
+ newdoc Changes ChangeLog
+}
diff --git a/dev-vcs/git-deploy/metadata.xml b/dev-vcs/git-deploy/metadata.xml
new file mode 100644
index 000000000000..115e717d1b5e
--- /dev/null
+++ b/dev-vcs/git-deploy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">git-deploy/git-deploy</remote-id>
+ </upstream>
+</pkgmetadata>