summaryrefslogtreecommitdiff
path: root/dev-vcs/git-crypt/git-crypt-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-crypt/git-crypt-0.7.0.ebuild')
-rw-r--r--dev-vcs/git-crypt/git-crypt-0.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-vcs/git-crypt/git-crypt-0.7.0.ebuild b/dev-vcs/git-crypt/git-crypt-0.7.0.ebuild
new file mode 100644
index 000000000000..d9424c732212
--- /dev/null
+++ b/dev-vcs/git-crypt/git-crypt-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Transparent file encryption in git"
+HOMEPAGE="https://www.agwa.name/projects/git-crypt/"
+SRC_URI="https://www.agwa.name/projects/git-crypt/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:=
+ dev-vcs/git
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-libs/libxslt"
+
+src_configure() {
+ # bug #805545, https://github.com/AGWA/git-crypt/issues/232
+ append-cppflags -DOPENSSL_API_COMPAT=0x30000000L
+ tc-export CXX
+
+ # bug #689180
+ export ENABLE_MAN=yes
+}
+
+src_install() {
+ dodir /usr/bin
+ emake PREFIX="${D}"/usr install
+}