summaryrefslogtreecommitdiff
path: root/dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild')
-rw-r--r--dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild b/dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..d1f3a018f685
--- /dev/null
+++ b/dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="transparent file encryption in git"
+HOMEPAGE="https://www.agwa.name/projects/git-crypt/"
+SRC_URI="https://github.com/AGWA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:=
+ dev-vcs/git
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p "${D}"/usr/bin || die
+ emake PREFIX="${D}"/usr install
+}