summaryrefslogtreecommitdiff
path: root/dev-vcs/git-big-picture
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-big-picture')
-rw-r--r--dev-vcs/git-big-picture/Manifest3
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.2.2-r1.ebuild41
-rw-r--r--dev-vcs/git-big-picture/metadata.xml4
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
index 446d57b42537..b47a7e58e9e9 100644
--- a/dev-vcs/git-big-picture/Manifest
+++ b/dev-vcs/git-big-picture/Manifest
@@ -3,5 +3,6 @@ DIST git-big-picture-1.2.1.tar.gz 2964502 BLAKE2B 1213c29e01c8556f694ecd12dcb397
DIST git-big-picture-1.2.2.tar.gz 2964564 BLAKE2B 39971b21a9c9a0a8d1bf41f37350a158b634d2eaa0add460c1c18b70f643ab226736d53a337d4ed2583903a5d6c3188ab7a1b06f48a3f354e28d57ec74441599 SHA512 62c43727bb688d6572e7caafe9c5da3b782504738dd0d83d5df675ba757e8be22a8630ec1863c07f0fd2e54549b2ccbd1250ba8f367a6f840afa7b8962c487e8
EBUILD git-big-picture-1.2.0.ebuild 889 BLAKE2B 3def5d0bc40f1051d5661c7fbc2eaf6de5ab82f12bc6610e79d5392488653a81f92e214b9411c052ae211f9b6716fdc0f134b9e3dbf3463a0159c6453f20177c SHA512 5de8adb1d17bfdad010e4169496943e59c8ae51ee4bd43c9f50674c7d45e781cc5ab53145a8b7a807b0b5414d6679186e800027e455ad791816dc7028cc4cbdb
EBUILD git-big-picture-1.2.1.ebuild 889 BLAKE2B 1bb995fb57d6e0613d31400de3072b2396fd7a5eb5fd412a50eb8ee3c6e858aa4acecaa89ef32c8c0dacd61f18b01b50df933ff09d6a14c0f8198c0be00af4ff SHA512 c69c4c9b0515dca95b10173bc0dc4874c3786515eba0a5ba0e605ccc7d2d3c38777eec6db8fd6fae0682f86edcc35fa00cf47d1abd430c0fe762274a861ff969
+EBUILD git-big-picture-1.2.2-r1.ebuild 974 BLAKE2B 53dc27a0f10a870ddd90d75ea2e1da83ff7547386a4884c6dc5b61d52ad7e6ccdc0cf527d1de0a57014e940cf0a45cc39d409b3b128907aa5f71637c30151cc0 SHA512 137854500b179e7d2ff1135cd9aaf04fb6279f8968658760b4cf99c05bd580a5af088b6629e25499475d0511874391cf930bcfb238a5bc53be55446329205f04
EBUILD git-big-picture-1.2.2.ebuild 889 BLAKE2B 7699f537203c2e84a9b5b705ce2e664c7e2750c972036ec8bf6e14db75891db068f2bbdd5f29ec823295c15d08b219220361010c01bb57948dbd5041dcfed12d SHA512 2144352cfebf5f6b31b4e9688e8319d25966e86b08553ec8def429799e69d326cda3193e5207b7924cc642cbdd6c5237f3220d1d7c8853b0f2de6fb5034c4f50
-MISC metadata.xml 250 BLAKE2B 2bc2e14adc90cf0097dec7f5c2eeeaebecbd404252555385c3455d81ea3a22eecc3dc27aa17699ab500fdfcb737f58a6cc981aeb691fe6266537c290655ca54f SHA512 913641ea55e6cbeb7ca80b13ed2161dd3d22e6d2f59408bf272c4a79e4590b4f2c726f4025d190e58617e262313fbf9ba0892b72773e4769466f812b5c009374
+MISC metadata.xml 399 BLAKE2B 5e912fe66108f5588e14b1766b905e2c19aa6bc8529ac855be153efa928222bd455eec6c21cbefbfa62fa005732356f0368b47eebd4bb91cfbb77ba427dbe356 SHA512 790e96e16572a401754dc67f30fd2bca0a1cf11ef95afca4cab8379fc1b2684389a73ce118e05c062c9ec768c0098240ab7ec1cda40e7ed1a81c0a3525ea1ba3
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.2.2-r1.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..26cb5b466ea7
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.2.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+# DISTUTILS_USE_PEP517=setuptools # blocked by use of distutils_install_for_testing
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram[${PYTHON_USEDEP}]
+ )
+"
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+
+ distutils_install_for_testing
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-vcs/git-big-picture/metadata.xml b/dev-vcs/git-big-picture/metadata.xml
index 6a22e9e318bb..eb74f28cf75b 100644
--- a/dev-vcs/git-big-picture/metadata.xml
+++ b/dev-vcs/git-big-picture/metadata.xml
@@ -5,4 +5,8 @@
<email>sping@gentoo.org</email>
<name>Sebastian Pipping</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">git-big-picture/git-big-picture</remote-id>
+ <remote-id type="pypi">git-big-picture</remote-id>
+ </upstream>
</pkgmetadata>