summaryrefslogtreecommitdiff
path: root/dev-vcs/cssc/cssc-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/cssc/cssc-1.4.1.ebuild')
-rw-r--r--dev-vcs/cssc/cssc-1.4.1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-vcs/cssc/cssc-1.4.1.ebuild b/dev-vcs/cssc/cssc-1.4.1.ebuild
index 5be7ce4bb7ea..3705d88715ba 100644
--- a/dev-vcs/cssc/cssc-1.4.1.ebuild
+++ b/dev-vcs/cssc/cssc-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,16 +13,15 @@ HOMEPAGE="https://www.gnu.org/software/cssc/"
SLOT="0"
LICENSE="GPL-3"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-IUSE="test valgrind"
+IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
- test? ( valgrind? ( dev-util/valgrind ) )
-"
+
DOCS=( AUTHORS ChangeLog NEWS README )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.4.1-m4.patch
)
+
S=${WORKDIR}/${CSSC_P}
src_prepare() {
@@ -31,8 +30,9 @@ src_prepare() {
}
src_configure() {
+ # Valgrind is only used for tests
econf \
- $(use test && use_with valgrind) \
+ --disable-valgrind \
--enable-binary
}