summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin69607 -> 69608 bytes
-rw-r--r--dev-util/blueprint-compiler/Manifest2
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild72
-rw-r--r--dev-util/valgrind/Manifest7
-rw-r--r--dev-util/valgrind/valgrind-3.22.0_rc1.ebuild5
-rw-r--r--dev-util/valgrind/valgrind-3.22.0_rc2.ebuild153
-rw-r--r--dev-util/valgrind/valgrind-9999.ebuild5
7 files changed, 164 insertions, 80 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index 5534f5092f52..ef5c5b749857 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/blueprint-compiler/Manifest b/dev-util/blueprint-compiler/Manifest
index 941d0da25298..85558e47729d 100644
--- a/dev-util/blueprint-compiler/Manifest
+++ b/dev-util/blueprint-compiler/Manifest
@@ -1,5 +1,3 @@
DIST blueprint-compiler-v0.10.0.tar.bz2 81856 BLAKE2B 8e63c27fc160244eb11776ea57c57b9c4b06aded76f3d59fc3190609f20a58985e3e800eebb5c69e681f8f8aba35f06f457f4dde241f78ff76d3e9348c4df46d SHA512 5d6a14a42aed64a82572a59730d454a920938d3b2c8aa1e61ab1d5fba47647ab5e3d6201c8ffe3e622b450ffcfb1eaf106951489897422c3e578d4d3695ae9ab
-DIST blueprint-compiler-v0.8.1.tar.bz2 80762 BLAKE2B 9acd4a8e2e5d993a94bcf2c80530553a8f6c8977ebe94274e6a208935f6ddaf21dd1946ab80e08b4e61e16a8ff892301d9f9cf82f7af6e8d53c3b2fce3996592 SHA512 94a4651a54d69df1bcfa3e7219cefb2eca187808d0c2a580c135583fa0e2848a011a72204a567c48fce20a246d41667f7cbf147a34980b34c0914b4fc5868efb
EBUILD blueprint-compiler-0.10.0.ebuild 1438 BLAKE2B 56cbcbe4622e0f2fc95ec8e7eade565114b8b492e8b551d9537cf667a1391e103fb978928beccf6e98cd67afb9ce45cbeedab53c81c165e84263b2d199d5a708 SHA512 3fcd96861116130252036a18d1522411d810ae2cf8b08bc169306a0c4bab358caee8d1e095495d2779959ded0b374a55e3a7599f4a44823104560f377b12bd2c
-EBUILD blueprint-compiler-0.8.1.ebuild 1438 BLAKE2B 56cbcbe4622e0f2fc95ec8e7eade565114b8b492e8b551d9537cf667a1391e103fb978928beccf6e98cd67afb9ce45cbeedab53c81c165e84263b2d199d5a708 SHA512 3fcd96861116130252036a18d1522411d810ae2cf8b08bc169306a0c4bab358caee8d1e095495d2779959ded0b374a55e3a7599f4a44823104560f377b12bd2c
MISC metadata.xml 906 BLAKE2B 8426e8a64268f0c3310028be81cc727a63ddd67df842d59eae80c55b12c41f446107cc61ed11c115da8b4cc9a67bb16b1d5c9dc09e541f41901eac29611f3e9d SHA512 3af397704e2717cbba16c890af04066cd67f40c1cc477429d3c53b713c079101036a17e788c0f5e316799cbfc8329356686ad129bfbed409002d96df3159d480
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild
deleted file mode 100644
index 4b1218894eed..000000000000
--- a/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit meson python-single-r1 virtualx
-
-DESCRIPTION="Compiler for Blueprint, a markup language for GTK user interfaces"
-HOMEPAGE="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/
- https://gitlab.gnome.org/jwestman/blueprint-compiler/"
-
-if [[ ${PV} == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.gnome.org/jwestman/${PN}.git"
-else
- SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
- S="${WORKDIR}"/${PN}-v${PV}
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="LGPL-3+"
-SLOT="0"
-IUSE="doc test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- ${RDEPEND}
- doc? (
- $(python_gen_cond_dep '
- dev-python/furo[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ')
- )
- test? (
- gui-libs/gtk:4[introspection]
- gui-libs/libadwaita:1[introspection]
- )
-"
-
-DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
-
-src_configure() {
- local -a emesonargs=(
- $(meson_use doc docs)
- )
- meson_src_configure
-}
-
-src_compile() {
- meson_src_compile
-
- use doc && build_sphinx docs
-}
-
-src_test() {
- virtx meson_src_test
-}
-
-src_install() {
- meson_src_install
- python_fix_shebang "${ED}"/usr/bin
- python_optimize
-}
diff --git a/dev-util/valgrind/Manifest b/dev-util/valgrind/Manifest
index b87359ac0ae1..2249ded9ada5 100644
--- a/dev-util/valgrind/Manifest
+++ b/dev-util/valgrind/Manifest
@@ -12,9 +12,12 @@ DIST valgrind-3.21.0.tar.bz2 17449484 BLAKE2B 1f7306d288eb5ecfb2b2f0b2dc68960ecd
DIST valgrind-3.21.0.tar.bz2.asc 488 BLAKE2B 6297bc925c16526a51de4f589232a8d5bcb8d54bdc885c145d329deeba45b42d3a5a8a3f59d3fb240d3bd78be7fd30d95ceb33c7624afd3c99c51833d0fd16f2 SHA512 114e5cd2f7352e56099efa3b2c42d39ed24e42419bbaac1af5e2b5c4fa72a2ba38ac6b0c60b93460a0cce8819ca0c7fae6618599b2af809ac0ab4fa30fdb25ba
DIST valgrind-3.22.0.RC1.tar.bz2 16414739 BLAKE2B 21b59e3c749c9a4fdab91568c942bd8a2c21ecadb053c88aa11563c739f8c87f403cd2a2bf03a3c6556c750a0190f2a1c4ff445355991f16d6f6a58b0be50fa1 SHA512 0aa9e98a959808d20cce53575433f81973ef3de3acc313ef2700f58cf9b2b7ee951b5bc701ef8508f5c136cb14239bbe7d81ae4208679ba55150b3edfd6078f0
DIST valgrind-3.22.0.RC1.tar.bz2.asc 488 BLAKE2B 938e032fc51e40c816fa6cec4fd95c6f183692d4d30988355bbb217984245fc7a0e6f70314f998511ab081bd2c5feeb217b025dcc84173afe7db7c04a9ebc063 SHA512 6b6518c633d40431bcf6836b0f0b67b44d7bf04a7b598dcd9707f479607a8cf9f6ca9320ddbf0d972db084c7e5bb5a02f866f5dc95c06e973d35597bf2f65695
+DIST valgrind-3.22.0.RC2.tar.bz2 17316447 BLAKE2B c0f70549d760ad599dff7d8a045e74441f42e77c7c208e19c5cec7599036dad683ef22bfd3a82f1f200a0acfbed616c33501264ff37cea773e99a31553658c03 SHA512 6a15101f4b92454856850fc35b9c38fd7fb294bee422274a803331465f347a732dc71e52c28e2d489c8d08ec7c677c1041bd32aeb4f43dd91ee404d4f6fa1208
+DIST valgrind-3.22.0.RC2.tar.bz2.asc 488 BLAKE2B 18a09f1edcaa1e26b821e30cb2cde962e3391c06bba1cac9dc72f304fd6e28d3f7586f0158b0429c792ea70ab3d9785b3e575bb1d700d4086f2a8279d35ae299 SHA512 117af5bb6758aab5a2bf2d18623254ce430399aea12c1943ee3c985ae1f0e579221144e9a0bf50ed03954f356264964c4d8f183b097739d810427bf876a212dd
EBUILD valgrind-3.20.0-r2.ebuild 4300 BLAKE2B a7c9b1f23d8e84375846633c1f91e48cf12ac40b9238b2f0d0edd3500c28706837ec1733f7c81e81c2469ae444e8153ea64670c1612e696205629171d3578019 SHA512 7ad54251e9ae5ac05dbb7bc5d59113d7c74cd3a98e1085e6c907672fde857ce2f5acd4ce02aa616db3e4aada01ad3e0923d5695b7e14623e3537dc316b27f823
EBUILD valgrind-3.21.0-r1.ebuild 4087 BLAKE2B 3e615ab2b642809cef8220734be89fd63b42bf33e725e28c6b9095f8f0b0036d072904447b8b8be3b42c3f7279c63baeb2398e034e4e414aadb399c2b3d9af1e SHA512 69a47d9c01df9f2e94a91dc7de85dfa11d0dd2d291682d607236c8f0de7cbc91c45a41c269ada95e8d341aafa0fbac83556219a0b0e593104ea27d5ed10cdb65
EBUILD valgrind-3.21.0-r2.ebuild 4459 BLAKE2B a7fa39fdcd43d30a396101eb073b05ba7e3c92c6f04eae0c63f9d2782742e3929d80aa77aceb7d887a862dc0f0491f0d8e671996270a371a1b40b414ee123e7d SHA512 5814b127f0a5870297056f07914a74dec21a50892ede7be5a730f255394578a15a99b888d053981277e2bc04b39ac92ec1467146fd729f77c6735f69358e74ae
-EBUILD valgrind-3.22.0_rc1.ebuild 4714 BLAKE2B 72f442412d3e569ef69c22c9ea1c719d5d9b70eae205967bb6f7f6daad8b2be5047eaabb4b78338df46b043d428e9a52432e6d7a93b2e86168ae98fac0b1f561 SHA512 317b6fd22f1ff4c20d6c7caba67d257f892b84eac33615b6986f7f53ed8c215cdaa248f64a68d19c17c1c04011400121b5ea22620b7c8d90baa2aa16eb171d61
-EBUILD valgrind-9999.ebuild 4714 BLAKE2B 72f442412d3e569ef69c22c9ea1c719d5d9b70eae205967bb6f7f6daad8b2be5047eaabb4b78338df46b043d428e9a52432e6d7a93b2e86168ae98fac0b1f561 SHA512 317b6fd22f1ff4c20d6c7caba67d257f892b84eac33615b6986f7f53ed8c215cdaa248f64a68d19c17c1c04011400121b5ea22620b7c8d90baa2aa16eb171d61
+EBUILD valgrind-3.22.0_rc1.ebuild 4853 BLAKE2B 44a6a82ff77d5a056661140a86fa6a42f3e321d565e5c4cbd80a0f029af9a6e403eb35db0f952452862d8abda01b7dcc670a8cc88da12a99b929c3ba550fb2e0 SHA512 0eb413c30240e8169504dc51d7461779979d33d84a8666c0b3ba99ec5dc8760718e6f048230d0a20e324baf3b76ea2e6c45d5e734635c33b320ae52f14b86bf9
+EBUILD valgrind-3.22.0_rc2.ebuild 4853 BLAKE2B 44a6a82ff77d5a056661140a86fa6a42f3e321d565e5c4cbd80a0f029af9a6e403eb35db0f952452862d8abda01b7dcc670a8cc88da12a99b929c3ba550fb2e0 SHA512 0eb413c30240e8169504dc51d7461779979d33d84a8666c0b3ba99ec5dc8760718e6f048230d0a20e324baf3b76ea2e6c45d5e734635c33b320ae52f14b86bf9
+EBUILD valgrind-9999.ebuild 4853 BLAKE2B 44a6a82ff77d5a056661140a86fa6a42f3e321d565e5c4cbd80a0f029af9a6e403eb35db0f952452862d8abda01b7dcc670a8cc88da12a99b929c3ba550fb2e0 SHA512 0eb413c30240e8169504dc51d7461779979d33d84a8666c0b3ba99ec5dc8760718e6f048230d0a20e324baf3b76ea2e6c45d5e734635c33b320ae52f14b86bf9
MISC metadata.xml 1037 BLAKE2B b39708a006ad3ff24b100c702382ec8c45f6e300f3497ccd06199a6195abfa936c8f71ebd3223e0f7299e6644e378ef1d8d2c95a23059b66757d8a91bcbfce15 SHA512 4398f60fdacedbd92881dea016e60c5def5abe8989b56fc450b71b5c65b0d9c26a44b8ee89d0dcb71ab376d987c8e22d12031e9fb2a17b126e3223adb12e0f2f
diff --git a/dev-util/valgrind/valgrind-3.22.0_rc1.ebuild b/dev-util/valgrind/valgrind-3.22.0_rc1.ebuild
index 26eb51e592fd..88c666067ac9 100644
--- a/dev-util/valgrind/valgrind-3.22.0_rc1.ebuild
+++ b/dev-util/valgrind/valgrind-3.22.0_rc1.ebuild
@@ -85,7 +85,7 @@ src_configure() {
# Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
# -fstack-protector-strong See -fstack-protector (bug #620402)
# -m64 -mx32 for multilib-portage, bug #398825
- # -ggdb3 segmentation fault on startup
+ # -fharden-control-flow-redundancy: breaks runtime ('jump to the invalid address stated on the next line')
# -flto* fails to build, bug #858509
filter-flags -fomit-frame-pointer
filter-flags -fstack-protector
@@ -93,7 +93,8 @@ src_configure() {
filter-flags -fstack-protector-strong
filter-flags -m64 -mx32
filter-flags -fsanitize -fsanitize=*
- replace-flags -ggdb3 -ggdb2
+ filter-flags -fharden-control-flow-redundancy
+ append-cflags $(test-flags-CC -fno-harden-control-flow-redundancy)
filter-lto
if use amd64 || use ppc64; then
diff --git a/dev-util/valgrind/valgrind-3.22.0_rc2.ebuild b/dev-util/valgrind/valgrind-3.22.0_rc2.ebuild
new file mode 100644
index 000000000000..88c666067ac9
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.22.0_rc2.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# The Valgrind upstream maintainer also maintains it in Fedora and will
+# backport fixes there which haven't yet made it into a release. Keep an eye
+# on it for fixes we should cherry-pick too:
+# https://src.fedoraproject.org/rpms/valgrind/tree/rawhide
+
+inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="https://valgrind.org"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://sourceware.org/git/${PN}.git"
+ inherit git-r3
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/valgrind.gpg
+ inherit verify-sig
+
+ MY_P="${P/_rc/.RC}"
+ SRC_URI="https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2"
+ SRC_URI+=" verify-sig? ( https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2.asc )"
+ S="${WORKDIR}"/${MY_P}
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ fi
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="mpi"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+if [[ ${PV} != 9999 ]] ; then
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-valgrind )"
+fi
+
+PATCHES=(
+ # Respect CFLAGS, LDFLAGS
+ "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+ "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+ "${FILESDIR}"/${PN}-3.21.0-glibc-2.34-suppressions.patch
+ "${FILESDIR}"/${PN}-3.21.0-memcpy-fortify_source.patch
+)
+
+src_prepare() {
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
+
+ # Don't force multiarch stuff on OSX, bug #306467
+ sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # upstream doesn't support this, but we don't build with
+ # Sun/Oracle ld, we have a GNU toolchain, so get some things
+ # working the Linux/GNU way
+ find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
+ sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
+ cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
+ fi
+
+ default
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --with-gdbscripts-dir="${EPREFIX}"/usr/share/gdb/auto-load
+ )
+
+ # Respect ar, bug #468114
+ tc-export AR
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -fstack-protector-all Fails same way as -fstack-protector/-fstack-protector-strong.
+ # Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
+ # -fstack-protector-strong See -fstack-protector (bug #620402)
+ # -m64 -mx32 for multilib-portage, bug #398825
+ # -fharden-control-flow-redundancy: breaks runtime ('jump to the invalid address stated on the next line')
+ # -flto* fails to build, bug #858509
+ filter-flags -fomit-frame-pointer
+ filter-flags -fstack-protector
+ filter-flags -fstack-protector-all
+ filter-flags -fstack-protector-strong
+ filter-flags -m64 -mx32
+ filter-flags -fsanitize -fsanitize=*
+ filter-flags -fharden-control-flow-redundancy
+ append-cflags $(test-flags-CC -fno-harden-control-flow-redundancy)
+ filter-lto
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf+=("--enable-only64bit")
+ fi
+
+ # Force bitness on darwin, bug #306467
+ use x64-macos && myconf+=("--enable-only64bit")
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf+=("--without-mpicc")
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # fxsave.o, tronical.o have textrels
+ emake LDFLAGS="${LDFLAGS} -Wl,-z,notext" check
+}
+
+src_install() {
+ default
+
+ if [[ ${PV} == "9999" ]]; then
+ # Otherwise FAQ.txt won't exist:
+ emake -C docs FAQ.txt
+ mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
+ fi
+
+ dodoc FAQ.txt
+
+ pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+
+ # See README_PACKAGERS
+ dostrip -x /usr/libexec/valgrind/vgpreload* /usr/$(get_libdir)/valgrind/*
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fix install_names on shared libraries, can't turn them into bundles,
+ # as dyld won't load them any more then, bug #306467
+ local l
+ for l in "${ED}"/usr/lib/valgrind/*.so ; do
+ install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "Valgrind will not work if libc (e.g. glibc) does not have debug symbols."
+ elog "To fix this you can add splitdebug to FEATURES in make.conf"
+ elog "and remerge glibc. See:"
+ elog "https://bugs.gentoo.org/214065"
+ elog "https://bugs.gentoo.org/274771"
+ elog "https://bugs.gentoo.org/388703"
+}
diff --git a/dev-util/valgrind/valgrind-9999.ebuild b/dev-util/valgrind/valgrind-9999.ebuild
index 26eb51e592fd..88c666067ac9 100644
--- a/dev-util/valgrind/valgrind-9999.ebuild
+++ b/dev-util/valgrind/valgrind-9999.ebuild
@@ -85,7 +85,7 @@ src_configure() {
# Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
# -fstack-protector-strong See -fstack-protector (bug #620402)
# -m64 -mx32 for multilib-portage, bug #398825
- # -ggdb3 segmentation fault on startup
+ # -fharden-control-flow-redundancy: breaks runtime ('jump to the invalid address stated on the next line')
# -flto* fails to build, bug #858509
filter-flags -fomit-frame-pointer
filter-flags -fstack-protector
@@ -93,7 +93,8 @@ src_configure() {
filter-flags -fstack-protector-strong
filter-flags -m64 -mx32
filter-flags -fsanitize -fsanitize=*
- replace-flags -ggdb3 -ggdb2
+ filter-flags -fharden-control-flow-redundancy
+ append-cflags $(test-flags-CC -fno-harden-control-flow-redundancy)
filter-lto
if use amd64 || use ppc64; then