summaryrefslogtreecommitdiff
path: root/dev-util/wstool/wstool-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/wstool/wstool-9999.ebuild')
-rw-r--r--dev-util/wstool/wstool-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
index 41972a54bea4..c6a9c3fd8897 100644
--- a/dev-util/wstool/wstool-9999.ebuild
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -13,7 +13,7 @@ fi
inherit ${SCM} distutils-r1
DESCRIPTION="Commands to manage several local SCM repositories for ROS"
-HOMEPAGE="http://wiki.ros.org/wstool"
+HOMEPAGE="https://wiki.ros.org/wstool"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
@@ -34,7 +34,6 @@ RDEPEND="
>=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- dev-python/sphinx
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
@@ -44,6 +43,9 @@ DEPEND="${RDEPEND}
dev-vcs/subversion
)
"
+BDEPEND="
+ dev-python/sphinx
+"
DISTUTILS_IN_SOURCE_BUILD="yes"