summaryrefslogtreecommitdiff
path: root/dev-util/wstool/wstool-0.1.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/wstool/wstool-0.1.17.ebuild')
-rw-r--r--dev-util/wstool/wstool-0.1.17.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-util/wstool/wstool-0.1.17.ebuild b/dev-util/wstool/wstool-0.1.17.ebuild
deleted file mode 100644
index 44cd350a809f..000000000000
--- a/dev-util/wstool/wstool-0.1.17.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/wstool"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Commands to manage several local SCM repositories for ROS"
-HOMEPAGE="http://wiki.ros.org/wstool"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/sphinx
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-vcs/git
- dev-vcs/bzr
- dev-vcs/mercurial
- dev-vcs/subversion
- )
-"
-
-PATCHES=( "${FILESDIR}/prefix2.patch" )
-DISTUTILS_IN_SOURCE_BUILD="yes"
-
-python_test() {
- # From travis.yml
- # Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
- # Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
- # Set the bzr user
- bzr whoami "Your Name <name@example.com>"
- # command to run tests
- nosetests --with-coverage --cover-package=wstool || die
-}