summaryrefslogtreecommitdiff
path: root/dev-util/wasm3/wasm3-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/wasm3/wasm3-0.5.0.ebuild')
-rw-r--r--dev-util/wasm3/wasm3-0.5.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/wasm3/wasm3-0.5.0.ebuild b/dev-util/wasm3/wasm3-0.5.0.ebuild
index 316033c51925..8ebb505db465 100644
--- a/dev-util/wasm3/wasm3-0.5.0.ebuild
+++ b/dev-util/wasm3/wasm3-0.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="A fast WebAssembly interpreter and the most universal WASM runtime"
HOMEPAGE="https://github.com/wasm3/wasm3/"
@@ -25,6 +25,10 @@ SLOT="0"
DOCS=( README.md docs )
src_configure() {
+ # bug https://bugs.gentoo.org/925933
+ filter-lto
+ append-flags -fno-strict-aliasing
+
local -a mycmakeargs=(
-DBUILD_WASI=simple
)