summaryrefslogtreecommitdiff
path: root/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/vulkan-tools/vulkan-tools-9999.ebuild')
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-9999.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
index 59d64d894e7a..ae7ec142589b 100644
--- a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
+++ b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_PN=Vulkan-Tools
PYTHON_COMPAT=( python3_{9..11} )
@@ -28,7 +28,6 @@ IUSE="cube wayland +X"
REQUIRED_USE="cube? ( ^^ ( X wayland ) )"
BDEPEND="${PYTHON_DEPS}
- >=dev-util/cmake-3.10.2
cube? ( ~dev-util/glslang-${PV}:=[${MULTILIB_USEDEP}] )
"
RDEPEND="
@@ -63,6 +62,7 @@ multilib_src_configure() {
-DCMAKE_SKIP_RPATH=ON
-DBUILD_VULKANINFO=ON
-DBUILD_CUBE=$(usex cube)
+ -DBUILD_WERROR=OFF
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
@@ -76,7 +76,3 @@ multilib_src_configure() {
cmake_src_configure
}
-
-multilib_src_install() {
- cmake_src_install
-}