summaryrefslogtreecommitdiff
path: root/dev-util/vulkan-headers/vulkan-headers-1.3.239.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/vulkan-headers/vulkan-headers-1.3.239.ebuild')
-rw-r--r--dev-util/vulkan-headers/vulkan-headers-1.3.239.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/vulkan-headers/vulkan-headers-1.3.239.ebuild b/dev-util/vulkan-headers/vulkan-headers-1.3.239.ebuild
new file mode 100644
index 000000000000..309f5cf64421
--- /dev/null
+++ b/dev-util/vulkan-headers/vulkan-headers-1.3.239.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=Vulkan-Headers
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/sdk-${PV}.0.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/${MY_PN}-sdk-${PV}.0
+fi
+
+DESCRIPTION="Vulkan Header files and API registry"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND=">=dev-util/cmake-3.10.2"