summaryrefslogtreecommitdiff
path: root/dev-util/volk/volk-1.3.280.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/volk/volk-1.3.280.0.ebuild')
-rw-r--r--dev-util/volk/volk-1.3.280.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-util/volk/volk-1.3.280.0.ebuild b/dev-util/volk/volk-1.3.280.0.ebuild
deleted file mode 100644
index 0bc16cce4612..000000000000
--- a/dev-util/volk/volk-1.3.280.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/zeux/volk.git"
- inherit git-r3
-else
- EGIT_COMMIT="vulkan-sdk-${PV}"
- SRC_URI="https://github.com/zeux/volk/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv"
- S="${WORKDIR}"/${PN}-${EGIT_COMMIT}
-fi
-
-DESCRIPTION="Meta loader for Vulkan API"
-HOMEPAGE="https://github.com/zeux/volk"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="~media-libs/vulkan-loader-${PV}:=[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}
- ~dev-util/vulkan-headers-${PV}
-"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DVOLK_INSTALL=on
- )
- cmake_src_configure
-}