summaryrefslogtreecommitdiff
path: root/dev-util/vint/vint-0.3.21-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/vint/vint-0.3.21-r1.ebuild')
-rw-r--r--dev-util/vint/vint-0.3.21-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/vint/vint-0.3.21-r1.ebuild b/dev-util/vint/vint-0.3.21-r1.ebuild
new file mode 100644
index 000000000000..ee5847259039
--- /dev/null
+++ b/dev-util/vint/vint-0.3.21-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Lint tool for Vim script language"
+HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.org/project/vim-vint/"
+SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.8.patch"
+)
+
+distutils_enable_tests pytest