summaryrefslogtreecommitdiff
path: root/dev-util/valgrind/valgrind-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/valgrind/valgrind-9999.ebuild')
-rw-r--r--dev-util/valgrind/valgrind-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-util/valgrind/valgrind-9999.ebuild b/dev-util/valgrind/valgrind-9999.ebuild
index 2b96d5f5150c..b7152e95dc5e 100644
--- a/dev-util/valgrind/valgrind-9999.ebuild
+++ b/dev-util/valgrind/valgrind-9999.ebuild
@@ -31,6 +31,15 @@ src_prepare() {
# Respect CFLAGS, LDFLAGS
eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # upstream doesn't support this, but we don't build with
+ # Sun/Oracle ld, we have a GNU toolchain, so get some things
+ # working the Linux/GNU way
+ find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
+ sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
+ cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
+ fi
+
# Allow users to test their own patches
eapply_user