summaryrefslogtreecommitdiff
path: root/dev-util/uncrustify/uncrustify-0.74.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/uncrustify/uncrustify-0.74.0.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-0.74.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.74.0.ebuild b/dev-util/uncrustify/uncrustify-0.74.0.ebuild
new file mode 100644
index 000000000000..e4c34c2bcb23
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.74.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-any-r1 ${scm_eclass}
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}