summaryrefslogtreecommitdiff
path: root/dev-util/uftrace/uftrace-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/uftrace/uftrace-0.9.1.ebuild')
-rw-r--r--dev-util/uftrace/uftrace-0.9.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/uftrace/uftrace-0.9.1.ebuild b/dev-util/uftrace/uftrace-0.9.1.ebuild
new file mode 100644
index 000000000000..60c4d3793442
--- /dev/null
+++ b/dev-util/uftrace/uftrace-0.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Function (graph) tracer for user-space"
+HOMEPAGE="https://github.com/namhyung/uftrace"
+SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/python:2.7
+ sys-devel/gcc:*[cxx]
+ sys-libs/ncurses:=
+ virtual/libelf:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" Makefile || die
+}