summaryrefslogtreecommitdiff
path: root/dev-util/trace-cmd/trace-cmd-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/trace-cmd/trace-cmd-9999.ebuild')
-rw-r--r--dev-util/trace-cmd/trace-cmd-9999.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/dev-util/trace-cmd/trace-cmd-9999.ebuild b/dev-util/trace-cmd/trace-cmd-9999.ebuild
index edebefd435ba..d38e2e55b21e 100644
--- a/dev-util/trace-cmd/trace-cmd-9999.ebuild
+++ b/dev-util/trace-cmd/trace-cmd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,29 +13,26 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/${PN}.git"
inherit git-r3
else
- SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git/snapshot/${PN}-v${PV}.tar.gz"
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/${PN}.git/snapshot/${PN}-v${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-v${PV}"
fi
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
-IUSE="doc gtk python udis86"
+IUSE="+audit doc python udis86"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )
- udis86? ( dev-libs/udis86 )
- gtk? (
- ${PYTHON_DEPS}
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- )"
+RDEPEND="audit? ( sys-process/audit )
+ python? ( ${PYTHON_DEPS} )
+ udis86? ( dev-libs/udis86 )"
DEPEND="${RDEPEND}
sys-kernel/linux-headers
python? (
virtual/pkgconfig
dev-lang/swig
)
- gtk? ( virtual/pkgconfig )
+
doc? ( app-text/asciidoc )"
CONFIG_CHECK="
@@ -45,6 +42,7 @@ CONFIG_CHECK="
PATCHES=(
"${FILESDIR}"/${PN}-2.7-makefile.patch
+ "${FILESDIR}"/${PN}-2.7-soname.patch
)
pkg_setup() {
@@ -53,7 +51,11 @@ pkg_setup() {
}
src_configure() {
- MAKEOPTS+=" prefix=/usr libdir=$(get_libdir) CC=$(tc-getCC) AR=$(tc-getAR)"
+ MAKEOPTS+=" prefix=/usr
+ libdir=/usr/$(get_libdir)
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ $(usex audit '' '' 'NO_AUDIT=1')"
if use python; then
MAKEOPTS+=" PYTHON_VERS=${EPYTHON//python/python-}"
@@ -66,13 +68,13 @@ src_configure() {
}
src_compile() {
- emake all_cmd
+ emake V=1 all_cmd libs
use doc && emake doc
- use gtk && emake -j1 gui
+
}
src_install() {
- default
+ emake DESTDIR="${D}" V=1 install install_libs
use doc && emake DESTDIR="${D}" install_doc
- use gtk && emake DESTDIR="${D}" install_gui
+
}