summaryrefslogtreecommitdiff
path: root/dev-util/sysprof-capture/sysprof-capture-3.40.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sysprof-capture/sysprof-capture-3.40.1.ebuild')
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.40.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.40.1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.40.1.ebuild
new file mode 100644
index 000000000000..0c08f4b82662
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.40.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson-multilib systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="!=dev-util/sysprof-3.34.1-r0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dlibunwind=false
+ -Denable_tools=false
+ -Denable_tests=false
+ -Denable_examples=false
+ )
+ meson_src_configure
+}