summaryrefslogtreecommitdiff
path: root/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild')
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild
new file mode 100644
index 000000000000..fb4cdee37666
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.61.3:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # In 3.34.1 -Dlibsysprof=false still installs various data files related with it;
+ # some of these seem fixed by 3.36
+ sed -i -e '/subdir.*data/d' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # In 3.36 these shouldn't be needed with with_sysprofd=none
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof2.xml || die
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml || die
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml || die
+}