summaryrefslogtreecommitdiff
path: root/dev-util/strace/strace-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/strace/strace-9999.ebuild')
-rw-r--r--dev-util/strace/strace-9999.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index db378889c0d5..c08dbf18c0a5 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/strace/strace.git"
inherit git-r3 autotools
else
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
@@ -22,6 +22,9 @@ IUSE="aio perl static unwind elfutils"
REQUIRED_USE="?? ( unwind elfutils )"
+BDEPEND="
+ virtual/pkgconfig
+"
LIB_DEPEND="
unwind? ( sys-libs/libunwind[static-libs(+)] )
elfutils? ( dev-libs/elfutils[static-libs(+)] )
@@ -37,9 +40,15 @@ RDEPEND="
perl? ( dev-lang/perl )
"
+PATCHES=(
+ "${FILESDIR}/${PN}-5.5-static.patch"
+)
+
src_prepare() {
default
+ eautoreconf
+
if [[ ! -e configure ]] ; then
# git generation
sed /autoreconf/d -i bootstrap || die
@@ -49,8 +58,6 @@ src_prepare() {
fi
filter-lfs-flags # configure handles this sanely
- # Add -pthread since strace wants -lrt for timer_create, and -lrt uses -lpthread.
- use static && append-ldflags -static -pthread
export ac_cv_header_libaio_h=$(usex aio)
use elibc_musl && export ac_cv_header_stdc=no
@@ -70,7 +77,9 @@ src_configure() {
# Don't require mpers support on non-multilib systems. #649560
local myeconfargs=(
+ --disable-gcc-Werror
--enable-mpers=check
+ $(use_enable static)
$(use_with unwind libunwind)
$(use_with elfutils libdw)
)