summaryrefslogtreecommitdiff
path: root/dev-util/strace/strace-5.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/strace/strace-5.5.ebuild')
-rw-r--r--dev-util/strace/strace-5.5.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/strace/strace-5.5.ebuild b/dev-util/strace/strace-5.5.ebuild
index c6b8e0324fbd..cf81c1cc50d4 100644
--- a/dev-util/strace/strace-5.5.ebuild
+++ b/dev-util/strace/strace-5.5.ebuild
@@ -3,14 +3,14 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs autotools
+inherit autotools flag-o-matic toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/strace/strace.git"
inherit git-r3 autotools
else
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
@@ -22,6 +22,9 @@ IUSE="aio perl static unwind elfutils"
REQUIRED_USE="?? ( unwind elfutils )"
+BDEPEND="
+ virtual/pkgconfig
+"
LIB_DEPEND="
unwind? ( sys-libs/libunwind[static-libs(+)] )
elfutils? ( dev-libs/elfutils[static-libs(+)] )
@@ -37,11 +40,13 @@ RDEPEND="
perl? ( dev-lang/perl )
"
+PATCHES=(
+ "${FILESDIR}/${PN}-5.5-static.patch"
+)
+
src_prepare() {
default
- # Needed for applied patch (#701516). Remove with next version.
- # Don't forget about autotools inherit.
eautoreconf
if [[ ! -e configure ]] ; then
@@ -53,8 +58,6 @@ src_prepare() {
fi
filter-lfs-flags # configure handles this sanely
- # Add -pthread since strace wants -lrt for timer_create, and -lrt uses -lpthread.
- use static && append-ldflags -static -pthread
export ac_cv_header_libaio_h=$(usex aio)
use elibc_musl && export ac_cv_header_stdc=no
@@ -75,6 +78,7 @@ src_configure() {
# Don't require mpers support on non-multilib systems. #649560
local myeconfargs=(
--enable-mpers=check
+ $(use_enable static)
$(use_with unwind libunwind)
$(use_with elfutils libdw)
)