summaryrefslogtreecommitdiff
path: root/dev-util/stepman/stepman-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/stepman/stepman-0.10.0.ebuild')
-rw-r--r--dev-util/stepman/stepman-0.10.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-util/stepman/stepman-0.10.0.ebuild b/dev-util/stepman/stepman-0.10.0.ebuild
deleted file mode 100644
index 4b0b891bc494..000000000000
--- a/dev-util/stepman/stepman-0.10.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-build
-
-EGO_ON="github.com/bitrise-io"
-EGO_PN="${EGO_ON}/${PN}"
-
-DESCRIPTION="Step collection manager for Bitrise CLI."
-HOMEPAGE="https://www.bitrise.io/cli"
-SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-S="${WORKDIR}/src/${EGO_ON}/${PN}"
-
-src_unpack() {
- unpack ${A}
- mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
- mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/stepman" || die "Couldn't move sources to GOPATH"
-}
-
-src_compile() {
- GOPATH="${WORKDIR}" go build -v -o bin/stepman || die "Couldn't compile stepman"
-}
-
-src_test() {
- export INTEGRATION_TEST_BINARY_PATH="${S}/bin/stepman"
- GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
-}
-
-src_install() {
- dobin bin/stepman
- dodoc README.md
-}