summaryrefslogtreecommitdiff
path: root/dev-util/squashdelta
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/squashdelta')
-rw-r--r--dev-util/squashdelta/Manifest4
-rw-r--r--dev-util/squashdelta/metadata.xml19
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.ebuild35
-rw-r--r--dev-util/squashdelta/squashdelta-9999.ebuild41
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-util/squashdelta/Manifest b/dev-util/squashdelta/Manifest
new file mode 100644
index 000000000000..aab027372dbc
--- /dev/null
+++ b/dev-util/squashdelta/Manifest
@@ -0,0 +1,4 @@
+DIST squashdelta-0.1.tar.bz2 77702 BLAKE2B c36a90e5bb0c22519fdd6229131039b881ccda82117a8180959e463debf767bc2382cc7e38645003cb23ae8e58492aaed849d1951adaedea56837900fda0025f SHA512 1ce93b59b6c51be49aaaee9576049677c8ba146fa3a17c7d3552440a1c0ebe93fb4d8cbe1182db691e2c9552713ecfeef0e50d95f7e94218c341c51364bf724f
+EBUILD squashdelta-0.1.ebuild 816 BLAKE2B ed9e06f2b254d3907872234733ee3bd18f203efd18668c1072e44c36b571da7d83510131de61d388c4b6c1b5d58b91f6c00f62939f12d351f47b4fd52616a44a SHA512 db8727fd723ce993b06fc4c12f769b412971c9042609d48f14a6e6bfe681511652e4253bcf57c0a8a20a855edd53c0989462974ba15291a50c61f86e64ff359f
+EBUILD squashdelta-9999.ebuild 812 BLAKE2B 87a425b61222a714e4a4868d5c86ca37ef58c1840137214edb349b1fdf3b94175ee65ece4252be5af89f992b5be4675c2f6b3e92b2133e974b0fe0427bea1748 SHA512 d3551e272526a4c105623bce97879012d998fe57d2bf31d795d9051da3427a7900916f0f8b90d5a725e45fbf3e1282413c13eb32c6eb0ba2faf6ad6fcc799ee0
+MISC metadata.xml 617 BLAKE2B 1a732150f235099533beb0b3672648f3d4e501509d754bc54f1cb9093df38b2c411519417433b1b485c922844814923c2925d699881f07cb0512b5edeb5f93a8 SHA512 a08f732876cfc4455ddd980eb04cffbe73b4bd56426d420777782a93b1229277463f85c71f05699f152f2edaa4ee8e029e1e5185b5c7b47204a9e9b9ba5120a2
diff --git a/dev-util/squashdelta/metadata.xml b/dev-util/squashdelta/metadata.xml
new file mode 100644
index 000000000000..1001cf9123ee
--- /dev/null
+++ b/dev-util/squashdelta/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="lz4">Enable support for LZ4 compression using <pkg>app-arch/lz4</pkg></flag>
+ </use>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://github.com/mgorny/squashdelta/issues/</bugs-to>
+ <remote-id type="github">mgorny/squashdelta</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/squashdelta/squashdelta-0.1.ebuild b/dev-util/squashdelta/squashdelta-0.1.ebuild
new file mode 100644
index 000000000000..64d107803421
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://github.com/mgorny/squashdelta/"
+SRC_URI="https://www.github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/squashdelta/squashdelta-9999.ebuild b/dev-util/squashdelta/squashdelta-9999.ebuild
new file mode 100644
index 000000000000..fd19fe305141
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
+inherit autotools git-r3
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://github.com/mgorny/squashdelta/"
+SRC_URI=""
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS=""
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ econf "${myconf[@]}"
+}