summaryrefslogtreecommitdiff
path: root/dev-util/spirv-tools/spirv-tools-2020.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/spirv-tools/spirv-tools-2020.1.ebuild')
-rw-r--r--dev-util/spirv-tools/spirv-tools-2020.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-util/spirv-tools/spirv-tools-2020.1.ebuild b/dev-util/spirv-tools/spirv-tools-2020.1.ebuild
deleted file mode 100644
index 3c8fb137c2e3..000000000000
--- a/dev-util/spirv-tools/spirv-tools-2020.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN=SPIRV-Tools
-CMAKE_ECLASS="cmake"
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-multilib python-any-r1
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
- S="${WORKDIR}"/${MY_PN}-${PV}
-fi
-
-DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
-HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-# Tests fail upon finding symbols that do not match a regular expression
-# in the generated library. Easily hit with non-standard compiler flags
-RESTRICT="test"
-COMMON_DEPEND=">=dev-util/spirv-headers-1.5.1"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND=""
-BDEPEND="${PYTHON_DEPS}
- ${COMMON_DEPEND}"
-
-multilib_src_configure() {
- local mycmakeargs=(
- "-DSPIRV-Headers_SOURCE_DIR=/usr/"
- "-DSPIRV_WERROR=OFF"
- )
-
- cmake_src_configure
-}