summaryrefslogtreecommitdiff
path: root/dev-util/spirv-llvm-translator/spirv-llvm-translator-18.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/spirv-llvm-translator/spirv-llvm-translator-18.1.0.ebuild')
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-18.1.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-18.1.0.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-18.1.0.ebuild
index acf2b6f81bde..63f846f23177 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-18.1.0.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-18.1.0.ebuild
@@ -41,6 +41,9 @@ PATCHES=(
src_prepare() {
append-flags -fPIC
cmake_src_prepare
+
+ # https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/2555
+ sed -i -e 's/%triple/x86_64-unknown-linux-gnu/' test/DebugInfo/X86/*.ll || die
}
src_configure() {