summaryrefslogtreecommitdiff
path: root/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild')
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
index bdefd6ed9703..29e6a6ab500f 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-15.0.0-r1.ebuild
@@ -40,6 +40,9 @@ PATCHES=( "${FILESDIR}"/${PN}-15.0.0-intel-capability.patch )
src_prepare() {
append-flags -fPIC
cmake_src_prepare
+
+ # https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/2555
+ sed -i -e 's/%triple/x86_64-unknown-linux-gnu/' test/DebugInfo/X86/*.ll || die
}
src_configure() {