summaryrefslogtreecommitdiff
path: root/dev-util/smem/smem-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/smem/smem-1.5.ebuild')
-rw-r--r--dev-util/smem/smem-1.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/smem/smem-1.5.ebuild b/dev-util/smem/smem-1.5.ebuild
new file mode 100644
index 000000000000..d536b2ed6a3e
--- /dev/null
+++ b/dev-util/smem/smem-1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit eutils python-single-r1 toolchain-funcs
+
+DESCRIPTION="A tool that can give numerous reports on memory usage on Linux systems"
+HOMEPAGE="https://www.selenic.com/smem/"
+SRC_URI="https://dev.gentoo.org/~conikost/files/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -o smemcap smemcap.c || die
+}
+
+src_install() {
+ dobin smemcap
+ python_doexe smem
+
+ dodoc README.txt
+ doman smem.8
+}
+
+pkg_postinst() {
+ optfeature "for chart generation." dev-python/matplotlib
+}