summaryrefslogtreecommitdiff
path: root/dev-util/shflags/shflags-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/shflags/shflags-1.0.3.ebuild')
-rw-r--r--dev-util/shflags/shflags-1.0.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/shflags/shflags-1.0.3.ebuild b/dev-util/shflags/shflags-1.0.3.ebuild
new file mode 100644
index 000000000000..a1bba5a8346f
--- /dev/null
+++ b/dev-util/shflags/shflags-1.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Command-line flags module for Unix shell scripts"
+HOMEPAGE="https://github.com/kward/shflags"
+SRC_URI="https://github.com/kward/shflags/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="examples"
+
+src_test() {
+ cd src || die
+ ./shflags_test.sh || die
+}
+
+src_install() {
+ dohtml README.html
+ dodoc README.txt doc/*.txt
+ insinto /usr/share/misc
+ doins src/shflags
+ use examples && dodoc examples/*.sh
+}