summaryrefslogtreecommitdiff
path: root/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild')
-rw-r--r--dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild b/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild
index 8085adc0f633..c6c33e14f8a3 100644
--- a/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild
+++ b/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild
@@ -1,28 +1,27 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-MY_PN=${PN/-bin/}
-BASE_URI="https://github.com/koalaman/${MY_PN}/releases/download/v${PV}/${MY_PN}-v${PV}.linux"
+SC_P=${PN%-bin}-v${PV}
+SC_URI="https://github.com/koalaman/shellcheck/releases/download/v${PV}/${SC_P}.linux"
DESCRIPTION="Shell script analysis tool (binary package)"
HOMEPAGE="https://www.shellcheck.net/"
SRC_URI="
- amd64? ( "${BASE_URI}".x86_64.tar.xz )
- arm? ( "${BASE_URI}".armv6hf.tar.xz )
- arm64? ( "${BASE_URI}".aarch64.tar.xz )
+ amd64? ( ${SC_URI}.x86_64.tar.xz )
+ arm64? ( ${SC_URI}.aarch64.tar.xz )
+ arm? ( ${SC_URI}.armv6hf.tar.xz )
"
+S=${WORKDIR}/${SC_P}
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="-* amd64 ~arm arm64"
-DEPEND="!dev-util/shellcheck"
-RDEPEND="${DEPEND}"
+RDEPEND="!dev-util/shellcheck"
-QA_PREBUILT="/usr/bin/shellcheck"
-S="${WORKDIR}/${MY_PN}-v${PV}"
+QA_PREBUILT="usr/bin/shellcheck"
src_install() {
dobin shellcheck