summaryrefslogtreecommitdiff
path: root/dev-util/scons/scons-4.5.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/scons/scons-4.5.1-r2.ebuild')
-rw-r--r--dev-util/scons/scons-4.5.1-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-util/scons/scons-4.5.1-r2.ebuild b/dev-util/scons/scons-4.5.1-r2.ebuild
index 0677fb162655..abf7ca5ec4a0 100644
--- a/dev-util/scons/scons-4.5.1-r2.ebuild
+++ b/dev-util/scons/scons-4.5.1-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 multiprocessing
@@ -47,7 +47,8 @@ src_unpack() {
# use the git directory structure, then unpack the pypi tarball
# on top of it to make our life easier
unpack "${P}.gh.tar.gz"
- tar -C "${P}" --strip-components=1 -xzf "${DISTDIR}/${MY_P}.tar.gz" || die
+ tar -C "${P}" --strip-components=1 --no-same-owner \
+ -xzf "${DISTDIR}/${MY_P}.tar.gz" || die
}
src_prepare() {