summaryrefslogtreecommitdiff
path: root/dev-util/scons/scons-3.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/scons/scons-3.1.2.ebuild')
-rw-r--r--dev-util/scons/scons-3.1.2.ebuild39
1 files changed, 4 insertions, 35 deletions
diff --git a/dev-util/scons/scons-3.1.2.ebuild b/dev-util/scons/scons-3.1.2.ebuild
index ef2605a2b114..8cd85f931c7d 100644
--- a/dev-util/scons/scons-3.1.2.ebuild
+++ b/dev-util/scons/scons-3.1.2.ebuild
@@ -17,21 +17,13 @@ SRC_URI="
doc? (
https://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf -> ${P}-user.pdf
https://www.scons.org/doc/${PV}/HTML/${PN}-user.html -> ${P}-user.html
- )
- test? ( https://github.com/scons/scons/archive/${PV}.tar.gz -> ${P}.gh.tar.gz )"
+ )"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/libxml2[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- )
-"
+IUSE="doc"
+RESTRICT="test"
S=${WORKDIR}/${P}/src
@@ -43,14 +35,7 @@ PATCHES=(
)
src_unpack() {
- # use the git directory structure, but put pregenerated release
- # inside src/ subdirectory to make our life easier
- if use test; then
- unpack "${P}.gh.tar.gz"
- else
- mkdir -p "${P}"/src || die
- fi
-
+ mkdir -p "${P}"/src || die
tar -C "${P}"/src --strip-components=1 -xzf "${DISTDIR}/${P}.tar.gz" || die
}
@@ -65,22 +50,6 @@ src_prepare() {
-e '/data_files/s:man/:share/man/:' "${S}"/setup.py || die
}
-python_test() {
- # set variable from escons() of scons-util.eclass to make env-passthrough patch work within test env
- local -x GENTOO_SCONS_ENV_PASSTHROUGH=1
- # unset some env variables to pass appropriate tests
- unset AR AS ASFLAGS CC CXX CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
- cd "${WORKDIR}/${P}" || die
- "${EPYTHON}" runtest.py -a --passed \
- -j "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
- --builddir "${BUILD_DIR}/lib"
-
- # runtest.py script returns "0" if all tests are passed
- # and returns "2" if there are any tests with "no result"
- # (i.e. in case if some tools are not installed or it's Windows specific tests)
- [[ ${?} == [02] ]] || die "Tests fail with ${EPYTHON}"
-}
-
python_install_all() {
local DOCS=( {CHANGES,README,RELEASE}.txt )
distutils-r1_python_install_all