summaryrefslogtreecommitdiff
path: root/dev-util/sasm/sasm-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sasm/sasm-9999.ebuild')
-rw-r--r--dev-util/sasm/sasm-9999.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/dev-util/sasm/sasm-9999.ebuild b/dev-util/sasm/sasm-9999.ebuild
index 023b24aab05d..61a911989dd0 100644
--- a/dev-util/sasm/sasm-9999.ebuild
+++ b/dev-util/sasm/sasm-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit qt4-r2
+inherit qmake-utils
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
@@ -15,7 +15,7 @@ else
fi
DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
-HOMEPAGE="http://dman95.github.io/SASM/"
+HOMEPAGE="https://dman95.github.io/SASM/"
LICENSE="GPL-3"
SLOT="0"
@@ -24,10 +24,20 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
- dev-qt/qtcore:4
- dev-qt/qtgui:4
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
"
REPEND="${DEPEND}
dev-lang/nasm
sys-devel/gdb
"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}