summaryrefslogtreecommitdiff
path: root/dev-util/rt-tests/rt-tests-2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rt-tests/rt-tests-2.4.ebuild')
-rw-r--r--dev-util/rt-tests/rt-tests-2.4.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-util/rt-tests/rt-tests-2.4.ebuild b/dev-util/rt-tests/rt-tests-2.4.ebuild
deleted file mode 100644
index 503b4965a276..000000000000
--- a/dev-util/rt-tests/rt-tests-2.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-single-r1 toolchain-funcs
-
-DESCRIPTION="A collection of latency testing tools for the linux(-rt) kernel"
-HOMEPAGE="https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git/"
-SRC_URI="
- https://kernel.org/pub/linux/utils/rt-tests/${P}.tar.xz
- https://kernel.org/pub/linux/utils/rt-tests/older/${P}.tar.xz"
-
-LICENSE="GPL-2 GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- sys-process/numactl"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- use elibc_musl && eapply "${FILESDIR}/${P}-musl.patch"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" AR="$(tc-getAR)"
-}
-
-src_install() {
- emake CC="$(tc-getCC)" prefix=/usr DESTDIR="${ED}" install
- python_fix_shebang "${ED}"
- python_optimize
-}