summaryrefslogtreecommitdiff
path: root/dev-util/rocminfo/rocminfo-5.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rocminfo/rocminfo-5.7.1.ebuild')
-rw-r--r--dev-util/rocminfo/rocminfo-5.7.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/rocminfo/rocminfo-5.7.1.ebuild b/dev-util/rocminfo/rocminfo-5.7.1.ebuild
new file mode 100644
index 000000000000..296b859a1fd3
--- /dev/null
+++ b/dev-util/rocminfo/rocminfo-5.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/rocminfo-rocm-${PV}"
+fi
+
+DESCRIPTION="ROCm Application for Reporting System Info"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
+LICENSE="UoI-NCSA"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocr-runtime-${PV}"
+DEPEND="${RDEPEND}"
+
+#PATCHES=(
+# "${FILESDIR}/${PN}-5.5.1-detect-builtin-amdgpu.patch"
+#)
+
+src_prepare() {
+ sed -e "/CPACK_RESOURCE_FILE_LICENSE/d" -i CMakeLists.txt || die
+ sed -e "/num_change_since_prev_pkg(/cset(NUM_COMMITS 0)" -i cmake_modules/utils.cmake || die # Fix QA issue on "git not found"
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( -DROCRTST_BLD_TYPE=Release )
+ cmake_src_configure
+}