summaryrefslogtreecommitdiff
path: root/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild')
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
new file mode 100644
index 000000000000..094ed9071adb
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-rocm-${PV}"
+
+src_install() {
+ cmake_src_install
+
+ rm -rfv "${ED}"/usr/share/doc/rocm-bandwidth-test
+}